OS X

From John's wiki
Jump to navigation Jump to search

Keyboard shortcuts

Read about other OS X keyboard shortcuts.

Mouse drag modifiers

Command key while dragging to another volume Move the dragged item to the other volume, instead of copying it.
Option key while dragging Copy the dragged item. The pointer changes while you drag the item.
Option-Command while dragging Make an alias of the dragged item. The pointer changes while you drag the item.

Software

Quicksilver is a desktop app launcher.

Setting process priority (nice level)

To set a process to full/first priority:

# renice -20 PID

Where PID is the Process ID. e.g.:

# renice -20 12345

You find the Process ID by looking for it in Activity Monitor or by using the 'ps' command, e.g.:

# ps aux

To set a process to lowest priority:

# renice 20 PID

e.g.:

# renice 20 12345

Finder: Show All Files

To show hidden files in finder:

$ defaults write com.apple.finder AppleShowAllFiles TRUE
$ killall Finder

To hide hidden files in finder:

$ defaults write com.apple.finder AppleShowAllFiles FALSE
$ killall Finder

Note: the finder config file is:

~/Library/Preferences/com.apple.finder.plist

Locking files and folders to prevent changes

To find out about chflags:

$ man chflags

The ucfg flag makes a folder immutable. To remove the uchg flag from a folder:

$ chflags nouchg FolderName

Single User Mode

To boot a Mac into single user mode: restart and hold down Command-S after the chime.

Darwin Ports

Use DarwinPorts to install software. E.g.

$ sudo port install subversion

Force Quit

To force a non-responsive app to quit: Apple+Option+Esc

Running svnserve via launchd

Create a plist,

$ vi /Library/LaunchDaemons/org.tigris.subversion.svnserve.plist

The plist file is an XML file that controls how the daemons runs, specifying the group/user, executable, parameters, sockets, etc.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
       <key>Debug</key>
       <false/>
       <key>GroupName</key>
       <string>staff</string>
       <key>Label</key>
       <string>org.tigris.subversion.svnserve</string>
       <key>OnDemand</key>
       <true/>
       <key>Program</key>
       <string>/usr/bin/svnserve</string>
       <key>ProgramArguments</key>
       <array>
               <string>svnserve</string>
               <string>--inetd</string>
               <string>--root=/Users/jj5/data/repo</string>
       </array>
       <key>ServiceDescription</key>
       <string>SVN Version Control System</string>
       <key>Sockets</key>
       <dict>
               <key>Listeners</key>
               <array>
               <dict>
                       <key>SockFamily</key>
                       <string>IPv4</string>
                       <key>SockServiceName</key>
                       <string>svn</string>
                       <key>SockType</key>
                       <string>stream</string>
               </dict>
               </array>
       </dict>
       <key>Umask</key>
       <integer>2</integer>
       <key>UserName</key>
       <string>jj5</string>
       <key>inetdCompatibility</key>
       <dict>
               <key>Wait</key>
               <false/>
       </dict>
</dict>
</plist>

To load and test:

$ sudo launchctl load /Library/LaunchDaemons/org.tigris.subversion.svnserve.plist
$ sudo launchctl start org.tigris.subversion.svnserve
$ svn co svn://condor/file file

To change the hostname

On Tiger (10.4) edit the /etc/hostconfig and specify HOSTNAME=.

On Leopard (10.5) use the command:

# /usr/sbin/systemsetup -setcomputername "condor"

Then reboot. Hmm, I tried that on Leopard but it didn't work.

$ man hostname
$ su
# hostname condor

That worked.

To nominate default language for spell check in Microsoft Word

In Word: Tools -> Language

== Installing Hardy Heron under VMWare Fusion on OS X 10.5 Leopard

Screenshots

Shortcut keys for screenshots: Command + Shift + 3. Also Command + Shift + 4